Elu Mof11 issue - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-05-2017, 07:13 AM Thread Starter
Registered User
 
Join Date: Jul 2017
Country: United Kingdom
First Name: Andy
Posts: 5
 
Default Elu Mof11 issue

Hi
My Elu Mof11 recently died on me - there was a big spark and then nothing. Question is, is it fixable? Does anyone have any ideas about what the issue could be, and does anyone know of anyone in the UK who can fix these things?
I could of course buy a new router but this was part of an overhead router set up and a new one would not fit.
thanks, Andy
andysmith is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-05-2017, 07:33 AM
Forum Contributor
 
Stick486's Avatar
 
Join Date: Jan 2013
Country: United States
First Name: Stick
Posts: 29,072
 
Default

where did the spark shoot out of???

This would have been the week that I'd have finished chewing thru the restraints...
If only new layers hadn't been added....

Stick....
Forget the primal scream, just ROAR!!!
"SNORK Mountain Congressional Library and Taxidermy”
Stick486 is online now  
post #3 of 6 (permalink) Old 07-05-2017, 10:54 AM
Moderation Team
 
Cherryville Chuck's Avatar
 
Join Date: Sep 2010
Country: Canada
First Name: Charles
Posts: 15,911
 
Default

It's possible that the spark might have been from a brush which might not be that serious or expensive. It's going to have to be at least partially dismantled to find out. If you do the opening up then a repair facility might do a quick diagnostic on it for free. If it's the armature then it is likely not worth fixing.

Someone I consider a master woodworker once told me that a master woodworker is not someone who never makes mistakes. He is someone who is able to cover them up so that no one can tell.
Cherryville Chuck is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-06-2017, 09:08 AM
Registered User
 
Join Date: Mar 2013
Country: United Kingdom
First Name: N/a
Posts: 1
 
Default

Hi, I think it's your brushes as Cherryville Chuck said. I had a similar problem with my Fein Multimaster earlier this year, spark, bang and burning smell. I live near High Wycombe in Bucks and took it into Isaac Lord, my local dealer. They fixed it for £25.00. You might have a similar dealer near you.
Good luck
Bo
beebole is offline  
post #5 of 6 (permalink) Old 07-06-2017, 09:50 AM
Moderation Team
 
Cherryville Chuck's Avatar
 
Join Date: Sep 2010
Country: Canada
First Name: Charles
Posts: 15,911
 
Default

Hi Bo and welcome to the forum. Thanks for the advice.

Someone I consider a master woodworker once told me that a master woodworker is not someone who never makes mistakes. He is someone who is able to cover them up so that no one can tell.
Cherryville Chuck is offline  
post #6 of 6 (permalink) Old 07-06-2017, 03:15 PM Thread Starter
Registered User
 
Join Date: Jul 2017
Country: United Kingdom
First Name: Andy
Posts: 5
 
Default

Thanks guys, I'll investigate further
andysmith is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Elu MOF 96 Setup guy.56 New Member Introductions 5 04-14-2015 06:13 PM
A Shipping Issue With Grizzly Jerry Bowen Lobby 12 05-13-2012 12:28 PM
Elu BobDz General Routing 1 08-09-2010 09:11 PM
ELU Routers ELU New Member Introductions 2 06-15-2010 12:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome