Bosch router 1617/18 EVS won't start - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-30-2010, 06:42 PM Thread Starter
Registered User
 
Frank G's Avatar
 
Join Date: May 2010
First Name: Frank
Posts: 2
 
Default Bosch router 1617/18 EVS won't start

Worked fine when last used (several months ago)

Outlet is hot.

Is the plastic cartridge on the power cord marked "do not open" a fuse. Dare I open it?

Anyone know a good repair shop near Great Falls, Va?

Thanks, Frank
Frank G is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-30-2010, 07:20 PM
Forum Contributor
 
Join Date: Jun 2009
Country: United States
First Name: John
Posts: 3,046
 
Default

Quote:
Originally Posted by Frank G View Post
Worked fine when last used (several months ago)

Outlet is hot.

Is the plastic cartridge on the power cord marked "do not open" a fuse. Dare I open it?

Anyone know a good repair shop near Great Falls, Va?

Thanks, Frank
Hi Frank, can you turn the thing freely by hand with it unplugged? Thing that bothers me is you said the "outlet is hot". Otherwise I would guess the switch. Might be the switch anyway, was a lot of discussion about the switches on those awhile back, maybe someone who has torn one apart will jump in here.

John Schaben

The problem with experience is I usually get it immediately after I need it.
jschaben is offline  
post #3 of 4 (permalink) Old 05-30-2010, 10:57 PM
Forum Contributor
 
Dr.Zook's Avatar
 
Join Date: Sep 2004
Country: United States
First Name: Dave or "Doc"
Posts: 10,715
 
Default

Hello Frank and let me welcome you to the RouterForums. Glad to have you join us.

John, I think Frank means the outlet is live, not hot to the touch. Hopefully.




Dave
the "Doctor"

In woodworking there is no scrap, only firewood.



Dr.Zook is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-31-2010, 07:27 AM Thread Starter
Registered User
 
Frank G's Avatar
 
Join Date: May 2010
First Name: Frank
Posts: 2
 
Default

John and Dave;

Thanks for quick reply. Yes, I meant the circuit is alive. and the shaft turns freely by hand. I DID unplug to turn the shaft!!!

I do suspect the rocker ON/OFF switch.

I hate to disassemble tools (right now I have a chain saw in pieces and an old Mccullough string trimmer that won't start--repair shops say "better buy a new one-- I charge too much!"); But I may take a look today at the router.

Thank you both. Frank
Frank G is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bosch Router Table Plate Pattern Rhino Starting Off 8 07-16-2015 11:37 PM
Bosch router table. Wood Doc Table-mounted Routing 0 05-18-2010 08:35 AM
Bosch RA 1180 Router Table & Skil Router sjrhynard Starting Off 4 01-15-2010 05:10 PM
Old Glossary Terms Mark Site Help and Suggestions 0 10-14-2008 01:30 AM
Bosch Router Table larryc Table-mounted Routing 1 07-06-2008 12:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome