Router Forums

Router Forums (https://www.routerforums.com/forum.php)
-   General Routing (https://www.routerforums.com/general-routing/)
-   -   Craftsman 17543 (https://www.routerforums.com/general-routing/25421-craftsman-17543-a.html)

cmsgtrlt 12-21-2010 08:56 PM

Craftsman 17543
 
Greetings,
I am new not only to this group, but to routing. I am a retired Air Force Chief Master Sergeant with a lot of time on my hands. I recently got a non working 17543 from EBAY????? It has power (LED lights and live tool), but no other functions (Motor not running). I replaced the pcb plate and have new brushes on order (back order from Sears)....The brushes on hand don't look bad, but looks could be deceiving.... Any suggestions....Thanks Rob Thompson

bobj3 12-21-2010 09:09 PM

Hi Ron

I would suggest to pop the hood and by pass the power switch..

=========

Quote:

Originally Posted by cmsgtrlt (Post 214789)
Greetings,
I am new not only to this group, but to routing. I am a retired Air Force Chief Master Sergeant with a lot of time on my hands. I recently got a non working 17543 from EBAY????? It has power (LED lights and live tool), but no other functions (Motor not running). I replaced the pcb plate and have new brushes on order (back order from Sears)....The brushes on hand don't look bad, but looks could be deceiving.... Any suggestions....Thanks Rob Thompson




jw2170 12-22-2010 01:49 AM

Hi Rob,

Welcome to the forum

xplorx4 12-23-2010 12:39 AM

Greetings and welcome to the router forum. Thank you for joining us, and remember to have fun, build well and above all be safe.


All times are GMT -5. The time now is 02:19 AM.

Powered by vBulletin® - Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.