My Milwaukee 5615 won't start - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-29-2010, 01:49 PM Thread Starter
Registered User
 
Join Date: Sep 2010
First Name: Tom
Posts: 4
 
Default My Milwaukee 5615 won't start

I cleaned the base of my 5615 Milwaukee router, wiped it dry and clean, and then reinstalled the motor. But it won't turn on now.

I see no reset switch, and fear I will have to send in a router I got for a hundred bucks for $150 of service.

Any ideas?
tomgnh is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-29-2010, 09:29 PM
Forum Contributor
 
Join Date: Jan 2006
Country: United States
First Name: Bj
Posts: 23,786
       
Default

Welcome to the RWS forum




"It's fine to disagree with other members as long as you respect their opinions"

Marc Sommerfeld Tools ,Videos
http://www.youtube.com/channel/UCT-n...RWaEpMA/videos

Find all threads started by bobj3
http://www.routerforums.com/search.php?searchid=944097


bobj3 is offline  
post #3 of 4 (permalink) Old 01-03-2011, 04:19 PM Thread Starter
Registered User
 
Join Date: Sep 2010
First Name: Tom
Posts: 4
 
Default

In frustration I plugged it in and tried it again. No problems!

Is this how the repair shops work? Make you wait until it fixes itself?
tomgnh is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-03-2011, 05:17 PM
Registered User
 
Mike Wingate's Avatar
 
Join Date: Apr 2009
Country: United Kingdom
First Name: mike
Posts: 1,124
 
Send a message via MSN to Mike Wingate
Default

No, just windows based PC's.
Mike Wingate is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
the truth about milwaukee an aeg tools toolsreview Tool Reviews 57 02-18-2014 10:07 AM
Milwaukee 5615 Aluminum Table Plate Help pottsgo Table-mounted Routing 7 10-09-2011 12:41 PM
PC 7519 Soft start removal for external speed control mwatso18 General Routing 4 11-23-2010 09:37 PM
Plunge bar -- Milwaukee 5615 TDDriver General Routing 6 11-08-2009 10:38 AM
Milwaukee table router height adjustment dharps Table-mounted Routing 2 09-21-2009 01:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome