bosch 1617 router - Router Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 07-03-2014, 08:49 AM Thread Starter
Registered User
 
reelwood's Avatar
 
Join Date: Jun 2014
Country: United States
First Name: John
Posts: 4
 
Default bosch 1617 router

Hello,
My Bosch router 1617 won't do anything when i attempt to start it ,it was fine two weeks ago when i last used it. No power ,no noise ,nothing. I have tried cleaning it with compressed air,nothing works any thoughts on that.I thought that maybe the brushes went bad. In the meantime I purchased the the same router at lowes so it would work on my table and other accessories as i was in the middle of some home improvements. What now.....
reelwood
reelwood is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 07-03-2014, 09:50 AM
BCK
Registered User
 
Join Date: Feb 2014
Country: Canada
First Name: BC
Posts: 786
 
Default

welcome aboard....might be the switch or wiring??try posting in appropriate area for more and better responses......enjoy

http://www.natures-lifestyles-digest.com/smf

above [link]site has: outdoors type things from fishing, hunting, boating, hiking, to living off grid, gardening from veggies to flowers etc, recipes from home cooking to smokers, hobbies, home remedies, to making your own soaps etc..live members chat area.. and more...all is welcome to browse or join..
BCK is offline  
post #3 of 12 (permalink) Old 07-03-2014, 11:40 AM
Moderation Team
 
Semipro's Avatar
 
Join Date: Mar 2013
Country: United States
First Name: John_*
Posts: 6,591
 
Default


John,Hello and welcome to router forums
How old is this router

Looking forward to your participation.
Filling out your profile to include (first name,tools and short bio is strictly (optional )but does help members to better relate to each other.
Thank You John
Semipro is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 07-03-2014, 05:32 PM Thread Starter
Registered User
 
reelwood's Avatar
 
Join Date: Jun 2014
Country: United States
First Name: John
Posts: 4
 
Default

It's about 4 years old,but prior to this it showed no sign of quitting on me no funny smell. I had made several pieces of molding cleaned it up then nothing?????
John
reelwood is offline  
post #5 of 12 (permalink) Old 07-03-2014, 05:58 PM
Official Greeter
 
jw2170's Avatar
 
Join Date: Jan 2008
Country: Australia
First Name: James
Posts: 18,460
 
Send a message via Skype™ to jw2170
Default

Welcome to the forum, John.

Thank you for joining us, .

You will find many on the forum, from hobbyists
to professional with similar interest in the router and its uses.

James
Sydney, Australia
.

I don't mind if other members disagree with my comments.
I don't profess to know everything, and I may learn something new.

"Never attribute to malice that which is adequately explained by stupidity."




jw2170 is offline  
post #6 of 12 (permalink) Old 07-03-2014, 06:17 PM
Registered User
 
Join Date: Aug 2009
Country: United States
First Name: Michael
Posts: 56
 
Default

John, give Bosch a call. Older models of this router have had switch failure problems. Might be your issue. They have sent replacement switches for free in the past.
Michael H is offline  
post #7 of 12 (permalink) Old 07-03-2014, 06:59 PM
Official Greeter
 
old55's Avatar
 
Join Date: Aug 2013
Country: Australia
First Name: Ross
Posts: 6,721
 
Default

Welcome to the forum John.

Ross,
Rockhampton, Queensland, Australia


Enjoy the knowledge of others that can be found within.

ĎMembers are requested to add a first name in their profile as we are a very friendly bunch here'.
old55 is offline  
post #8 of 12 (permalink) Old 07-04-2014, 06:54 AM
Registered User
 
Join Date: Jul 2012
Country: United States
First Name: Gary
Posts: 745
 
Default

John, Most Bosch tools use what they call "smart brushes". What they have done is embed a spring loaded plastic finger into the carbon brushes. When the brushes wear to a predetermined size the finger contacts the commutator and pushes the brushes away from the commutator to tell you it's time to replace. You might want to remove the brushes first to see if that is the problem.
gmercer_48083 is offline  
post #9 of 12 (permalink) Old 07-04-2014, 08:09 AM
Registered User
 
Join Date: Oct 2013
Country: United States
First Name: PAD3
Posts: 47
 
Default

I have had the same problem. It is the on/off switch that is the probable problem (Occam’s Razor) and the solution is to have Bosch send you a new one. Just call the toll free number. It is a very simple operation to change one. To keep the router working take the switch out, open it, clean the switch, replace and the router will probably start. Practice for replacing the switch when the new one arrives.

Last edited by PAD3; 07-04-2014 at 08:13 AM.
PAD3 is offline  
post #10 of 12 (permalink) Old 07-06-2014, 07:20 PM Thread Starter
Registered User
 
reelwood's Avatar
 
Join Date: Jun 2014
Country: United States
First Name: John
Posts: 4
 
Default

good ideas, I will get on it in the morning
reelwood is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ridgid R2930 (fixed and plunge base routee) xplorx4 Tool Reviews 15 09-23-2014 08:15 AM
Newbie in using a Router..... Andron General Routing 6 03-20-2013 02:20 PM
Bosch Router theenglishman1 Table-mounted Routing 8 12-31-2012 07:04 AM
Motorized Router Lift - Eagle Lake Style johnwnixon Table-mounted Routing 14 05-23-2012 04:51 PM
Adapting a Bosch 1617 router glfinneyirish Table-mounted Routing 4 01-02-2012 08:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome