Old Kenwood Vacuum Cleaner. - Router Forums
 6Likes
  • 5 Post By jj777746
  • 1 Post By TenGees
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-15-2019, 01:01 AM Thread Starter
Registered User
 
jj777746's Avatar
 
Join Date: Jan 2015
Country: Australia
First Name: James
Posts: 3,708
 
Default Old Kenwood Vacuum Cleaner.

Hi All, years ago my dear departed mother gave me a Kenwood vacuum which she said was too noisy. After a thorough cleaning of the inside filter & the cloth bag I've found it to be the strongest vacuum I have ever used. I had it hooked up to my previous RT fence dust port & it will be used the same way when my new RT is finished. I don't suppose there are many of these old vacuums still in existence but,there might be a few kicking around in other countries as well as here in OZ,so if anyone happens to see a "working"one at a yard/garage sale,buy it & be surprised at how good they are. They don't make 'em like this anymore. BTW, it was made in the USA. Jamesjj777746

You can't drive a bridge spike with a tack hammer(so I'm told)
jj777746 is online now  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-15-2019, 06:44 AM
Moderation Team
 
difalkner's Avatar
 
Join Date: Jan 2012
Country: United States
First Name: David
Posts: 2,434
 
Default

Photos?

David

David

Curly Wood Shop on Etsy
David Falkner - Woodworking YouTube channel
Our music at church - current videos Airline Baptist BC Facebook Live
Romans 3:23
difalkner is offline  
post #3 of 4 (permalink) Old 07-15-2019, 09:47 AM
Registered User
 
TenGees's Avatar
 
Join Date: Sep 2012
Country: Canada
First Name: Paul
Posts: 1,493
 
Default

I had one, then acquired another similar one from the trash at work. Swapping parts, I managed to keep them running for decades. They were decent vacuums, often with a power head - great for homes with pets.
jj777746 likes this.

Sent from my Hallicrafters S-40 using morse code.
TenGees is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-15-2019, 07:02 PM Thread Starter
Registered User
 
jj777746's Avatar
 
Join Date: Jan 2015
Country: Australia
First Name: James
Posts: 3,708
 
Default

@ difalkner, Hi David, I don't own a camera but our kids are all experts with theirs,lol, so I shall get one to post a couple of pics on the weekend or before. I also want to show my new miter saw & the router table I'm building. James.

You can't drive a bridge spike with a tack hammer(so I'm told)
jj777746 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome