Porter Cable 890 speed problem - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-14-2010, 06:20 PM Thread Starter
Registered User
 
Join Date: Sep 2008
Posts: 1
 
Default Porter Cable 890 speed problem

I am a new forum member, greetings. I have used a PC 890 in my work for at least 5 years without incident. I have found it to have been a well made tool. That being said, It was in a damp/rainy location overnight and will not attain rpm when turned on. I blew it out with compressed air the morning after it got wet, then used some electrical contact/equipment cleaner and more air.
Sometime it will start and hit rpm through two or three on-off cycles then revert to a very slow and strained speed.
Anyone have experience troubleshooting this type of malfunction? I would appreciate any information you may be able to provide.
Thank you. Steve
sjwbuild is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-14-2010, 06:27 PM
Forum Contributor
 
Join Date: Jan 2006
Country: United States
First Name: Bj
Posts: 23,786
       
Default

Hi


Try this, chuck up a true 1/4" rod. put your bat. power drill on the rod and spin it...but not to fast, be sure it is unplugged ..than take the rod out and hit the power switch..

======

Quote:
Originally Posted by sjwbuild View Post
I am a new forum member, greetings. I have used a PC 890 in my work for at least 5 years without incident. I have found it to have been a well made tool. That being said, It was in a damp/rainy location overnight and will not attain rpm when turned on. I blew it out with compressed air the morning after it got wet, then used some electrical contact/equipment cleaner and more air.
Sometime it will start and hit rpm through two or three on-off cycles then revert to a very slow and strained speed.
Anyone have experience troubleshooting this type of malfunction? I would appreciate any information you may be able to provide.
Thank you. Steve



"It's fine to disagree with other members as long as you respect their opinions"

Marc Sommerfeld Tools ,Videos
http://www.youtube.com/channel/UCT-n...RWaEpMA/videos

Find all threads started by bobj3
http://www.routerforums.com/search.php?searchid=944097


bobj3 is offline  
post #3 of 3 (permalink) Old 02-15-2010, 01:11 AM
Forum Contributor
 
Dr.Zook's Avatar
 
Join Date: Sep 2004
Country: United States
First Name: Dave or "Doc"
Posts: 10,715
 
Default

Hello Steve, welcome to the RouterForums. Happy to have you join us.




Dave
the "Doctor"

In woodworking there is no scrap, only firewood.



Dr.Zook is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Porter Cable 55160 Omnijig Review Echonav Tool Reviews 19 06-21-2015 03:59 AM
Problem with porter cable dovetail jig ldsmith1234 Jigs and Fixtures 8 11-03-2013 01:09 PM
Problem with Porter Cable 892 router the_nite_owl Tools and Woodworking 6 03-06-2011 10:31 PM
Bosch 1617vs Verses 690 Porter cable Glenmore Tool Reviews 20 08-09-2009 10:36 PM
Porter Cable 890 problem? Birch General Routing 4 03-29-2009 11:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome