loose collet on Hitachi m12V - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-04-2012, 10:11 AM Thread Starter
Registered User
 
Join Date: Jun 2012
Country: United States
First Name: Jim
Posts: 1
 
Default loose collet on Hitachi m12V

The collet has worked loose on my Hitachi m12V. I haven't experienced this before. Is there a way to tighten it up, or would the use of the router tighten it up? It is mounted in a router table. Any help would be appreicated.
Jim
jheater is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1/4" Collet for Hitachi M12V RzzB General Routing 53 07-26-2011 10:32 AM
Hitachi M12V Loose Collet/Lost Magnet rmaxey General Routing 5 10-31-2009 05:23 PM
Hitachi M12V Collet chuck loose idkjs General Routing 1 11-29-2005 09:36 AM
Hitachi M12V issue Warren White General Routing 4 03-23-2005 10:03 PM
Hitachi M12V Router Problem dcarriere Tools and Woodworking 3 12-28-2004 06:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome