Mach 3 problem - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-28-2013, 08:58 AM Thread Starter
Registered User
 
Join Date: Nov 2013
Country: Australia
First Name: N/a
Posts: 2
 
Default Mach 3 problem

Gday guys,
I am having trouble getting my cnc to do what it is told.
The machine works fine when operated manually from Mach 3 but when I try to run a G code file it goes to the G54 without a problem but then goes straight through the workpiece.
Below are the steps I take from beginning to disaster.

1. Home machine ( zeros on all axis in DRO Machine Coords )
2. Move spindle to centre of workpiece ( zero all axis on DRO )
3. Regen toolpath.
4. Move spindle away and hit go to zero to test G54 OK.
5. Enter spindle speed and hit Cycle start.

Result.( I removed the workpiece just in case )
1.Spindle does not start. ( Spindle used to start before G Code modification )
2.Spindle goes to top ( Home limit )
3.Spindle decends to machine bed and starts to go through program.

cheers

Trevor
Harro is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-28-2013, 11:27 AM
Moderation Team
 
Semipro's Avatar
 
Join Date: Mar 2013
Country: United States
First Name: John_*
Posts: 6,674
 
Default

Hello Trevor.
welcome to the forum,

Looking forward to your participation.
Filling out your profile to include (first name,tools and short bio is strictly (optional )but does help members to better relate to each other.
Thank You John
Semipro is online now  
post #3 of 8 (permalink) Old 11-28-2013, 04:00 PM
Official Greeter
 
jw2170's Avatar
 
Join Date: Jan 2008
Country: Australia
First Name: James
Posts: 18,547
 
Send a message via Skype™ to jw2170
Default

Welcome to the forum.

James
Sydney, Australia
.

I don't mind if other members disagree with my comments.
I don't profess to know everything, and I may learn something new.

"Never attribute to malice that which is adequately explained by stupidity."




jw2170 is online now  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-29-2013, 01:37 AM
Official Greeter
 
old55's Avatar
 
Join Date: Aug 2013
Country: Australia
First Name: Ross
Posts: 6,922
 
Default

Welcome to the forum Trevor.

Ross,
Rockhampton, Queensland, Australia


Enjoy the knowledge of others that can be found within.

‘Members are requested to add a first name in their profile as we are a very friendly bunch here'.
old55 is offline  
post #5 of 8 (permalink) Old 11-30-2013, 05:24 AM
Registered User
 
twcustoms's Avatar
 
Join Date: Oct 2013
Country: United States
First Name: will
Posts: 54
 
Default

what is the source of the g-code? Anyway you can take a screenshot of the g-code?
twcustoms is offline  
post #6 of 8 (permalink) Old 12-02-2013, 06:11 AM
Registered User
 
Join Date: Jan 2010
Country: Australia
First Name: Trevor
Posts: 7
 
Default Mach3 probs

Gday guys,
the source of the G code is Vectric Aspire.
Its on my workshop computer so I will post a screen shot tomorrow.
The G Code is a smile circle .

cheers

Trevor
Harrow is offline  
post #7 of 8 (permalink) Old 12-02-2013, 06:14 AM
Registered User
 
Join Date: Jan 2010
Country: Australia
First Name: Trevor
Posts: 7
 
Default

Bit of a typing error there.
It should read SIMPLE CIRCLE.

cheers

Trevor
Harrow is offline  
post #8 of 8 (permalink) Old 12-02-2013, 07:23 PM Thread Starter
Registered User
 
Join Date: Nov 2013
Country: Australia
First Name: N/a
Posts: 2
 
Default Mach 3 Problem

Gday guys,
Please find attached the simple circle G Code I am using for a tester.
G Code produced by Aspire.
Hope you can cast some light on my problem!!

cheers

Trevor
Attached Thumbnails
Click image for larger version

Name:	SIMPLE CIRCLE TEST.PNG
Views:	46
Size:	60.2 KB
ID:	67039  

Harro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem With PC 4212 Jig dppatt Jigs and Fixtures 4 05-27-2013 01:44 PM
Problem With This Forum Or What Jerry Bowen Tools and Woodworking 9 05-05-2013 05:56 AM
Using two touch plates and the Mach Blue Big Tex screen with Mach bloomingtonmike CNC Routing 0 02-07-2012 02:32 PM
Makita 3612C collet problem W C Slad General Routing 10 01-16-2012 09:53 AM
Problem with my Hitachi M12V Visteonguy Table-mounted Routing 23 08-18-2005 11:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome