Router Forums - Reply to Topic
Thread: Jet 16-32 problem Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-30-2018 05:24 PM
Oakwerks
Quote:
Originally Posted by TwoSkies57 View Post
Isn't the drum hollow? Couldn't you lossen up the holder, fish it thru the other end? I have a Ryobi 16/32 and the drums look identical.

plan B: coud you fit a needle nose pliar in and get ahold of the spring to reposition?
Good suggestion ..... I was able to hook a wire to it and pull thru to the other
end of the drum.... Lots of room to get it out on that side....
The end of pin that goes thru the small spring is broken ....

Ordered a new one from Ereplacementparts website.... $18.82 .....
08-30-2018 03:54 PM
Oakwerks
Quote:
Originally Posted by Garyk View Post
Haven't had the same problem as you but I have dismantled mine a few time for maintenance. It's just a matter of time & patience with the disassembly and re-assembly process. Parts should be easy to come by. Maybe it's just me but I enjoy the process. I learned patience from years or rebuilding Classic aircraft. You never rush maintenance on something that might kill you if done wrong.
I got the clamp mounting bolt out, but thereís not
enough clearance around the drum and the frame to
remove the clamp.....
Looks like I just need to back out the set screw that
locks the key to the shaft on the motor side, and the drum
can slide to the left enough to get the clamp out.... I hope....
08-30-2018 03:13 PM
Garyk Haven't had the same problem as you but I have dismantled mine a few time for maintenance. It's just a matter of time & patience with the disassembly and re-assembly process. Parts should be easy to come by. Maybe it's just me but I enjoy the process. I learned patience from years or rebuilding Classic aircraft. You never rush maintenance on something that might kill you if done wrong.
08-29-2018 09:04 PM
Oakwerks I (we) think we have it figured out ....
I called in my engineer better half to look at it.
She wanted to look at the exploded view in the
manual.... Looks like the little bolt that shows
on the surface of the drum is the only thing
that secures the clamp ..... If I can get needle
nose pliers, or something, on the nut underneath,
I think I can get it out, fix it, and reinstall it ....
08-29-2018 07:26 PM
hawkeye10
Quote:
Originally Posted by Oakwerks View Post
While changing the sanding belt, I tried to use the tool to hold the right hand sanding belt clamp open, and somehow broke the clamp loose ....The only way, I see, to fix it is to remove the drum....
I hate to just tear into it without checking with you guys to see if any of you
have any experience fixing this problem....
Kurt, call Jet for advice. I have called them in the past and they are helpful. They are about 20 miles from so if you have a problem with them I will go and whack them on the head.
08-29-2018 05:46 PM
TwoSkies57 Isn't the drum hollow? Couldn't you lossen up the holder, fish it thru the other end? I have a Ryobi 16/32 and the drums look identical.

plan B: coud you fit a needle nose pliar in and get ahold of the spring to reposition?
08-29-2018 05:40 PM
Oakwerks [QUOTE=TwoSkies57;1963643]Kurt...

Is it possible that a single flat head machine screw is what holds the "inboard take up fastener" in place?[/QUOTE

I just went out with a dental mirror, and it
looks like the pin that goes thru the spring
is out out of one side .... Donít see anything
broke....
But thereís no way to fix it without taking
the drum out ....
08-29-2018 05:06 PM
TwoSkies57 Kurt...

Is it possible that a single flat head machine screw is what holds the "inboard take up fastener" in place?
08-29-2018 03:41 PM
Herb Stoops Sorry to hear about that. I never broke the clamp, even though it was a big pita to get tight. But I can see your dilemma on how to get at the clip to fix it. You might contact Jet and see if they have any suggestions. In fact I have a SuperMax now and they are the same set up. If Jet doesn't respond maybe the Supermax people can help, they are good people and the original owners and designers of the Jet are the ones who started and designed SuperMax. Laguna is their owner now.

Herb
08-29-2018 01:16 PM
Oakwerks
Jet 16-32 problem

While changing the sanding belt, I tried to use the tool to hold the right hand sanding belt clamp open, and somehow broke the clamp loose ....The only way, I see, to fix it is to remove the drum....
I hate to just tear into it without checking with you guys to see if any of you
have any experience fixing this problem....

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome