Router Forums - Reply to Topic
Thread: Ryobi RE175 - Will not stay/lock in plunge position Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-17-2011 12:22 PM
dutchman 46
Quote:
Originally Posted by Router Newbie View Post
I had the same problem with my Bosch POF 500A. Replaced the missing brass piece with a small ball bearing inside the locking handle slot. I was cautioned to tighten gently as it can damage the plunging rods if too tight. Fortunately I found the missing piece the next day on my garage floor.
Thanks Stan! Something very important information! Might put it in the Ryobi folder. It's the only thing that ever went wrong with Mine!
06-17-2011 02:13 AM
Router Newbie I had the same problem with my Bosch POF 500A. Replaced the missing brass piece with a small ball bearing inside the locking handle slot. I was cautioned to tighten gently as it can damage the plunging rods if too tight. Fortunately I found the missing piece the next day on my garage floor.
06-13-2011 07:53 AM
dutchman 46 Hello N/a
I would guess that for some reason, the brass pad ,very small, slipped out of it's proper place! I have had that happened several times! I had the plunge handle loose. If memory serves Me, there is a small brass piece (1/4 by 3/42), or close to that. It can slide out of the hole and back inside the router! I needed to take it apart, and tap the unite on a piece of wood, covered with white cloth and it fell out. Then with a tweezers, put it back in place. It rubs on the shaft, I believe, and when You release the button, it grabs the shaft. I could not tell anything was wrong by touch. It felt OK. So it is worth a try!
06-04-2011 07:36 AM
no1texan
Ryobi RE175 - Will not stay/lock in plunge position

My Ryobi RE175 will not stay or lock in the plunge position.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome