Router Forums - Reply to Topic
Thread: Ridgid 2901 router Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-28-2011 01:08 PM
N'awlins77 I didn't get a chance to look into it today, but I will soon!! I'll post here what I find.
08-28-2011 11:29 AM
papawd Welcome
08-28-2011 11:04 AM
morrow47 Thanks James, I look forward to reading the forum.

Lee, If you come up with something let me know. It would be nice to adjust the router from the top without bending over to hold the router in place.
08-28-2011 06:05 AM
N'awlins77 Welcome to the forum John. And yes I have the same router combo (notice my avatar) and yes, I do have had that same problem on occasions. I guess I've just learned to hold a little pressure on the release lever. One day I'm going to give a try at putting a stronger spring on the release lever. Might even take a look at that this morning. I'll let you know what I find. Other then that, like you, I love the router!
08-28-2011 05:28 AM
jw2170 G'day John

Welcome to the router forum.

Thank you for joining us

I use a Triton router in my table , so don't have that problem
08-27-2011 04:44 PM
morrow47
Ridgid 2901 router

I have my router model 2901 and base 2911 attached to a bosch router table top. This combination works great, the router seems to have plenty of power.
I do experince one problem with the router, when I turn the adjustment knob or adjust from the top of the table, the router will slip out of the base if I don't have it supported with my hand. The tab that holds the router to the base moves out of the indent, which allows the motor to slip.
Has anyone else experienced this problem?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome