Just received a JessEm™ Rout-R-Lift II™ from Lee Valley - Router Forums
 22Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 54 (permalink) Old 02-19-2016, 10:45 AM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Cool Just received a JessEm™ Rout-R-Lift II™ from Lee Valley

It doesn’t fit my MLCS Router Table which I knew it wouldn’t from the specs, but it’s not as bad as I figured.



My brand new Keen Router Table Dust fitting does not quite fit the Rout-R-Lift II either. I’m not sure what I’m going to do about it. I may have to box it up and sell it because it’s been a little too long since I bought it to return it.



I never even got to use my Keen Router Table Dust system because the connector doesn’t fit the MLCS Router Table fence port.
Murtu01 likes this.
JohnnyB60 is offline  
Sponsored Links
Advertisement
 
post #2 of 54 (permalink) Old 02-19-2016, 11:14 AM
Registered User
 
Join Date: Dec 2015
Country: Canada
First Name: Keith
Posts: 1,151
 
Default

What about a little creative thinking to make the lift fit better.

Maybe route the top out some more to make the space wider, then make up a filler piece for a snug fit. Might work.

As for the vac fitting...surely there must be some way you can adapt that to work.
JohnnyB60 likes this.

OK, fess up...which one of you clowns stole my sig? It was right here a second ago.
cocobolo1 is offline  
post #3 of 54 (permalink) Old 02-19-2016, 11:35 AM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Default

Quote:
Originally Posted by cocobolo1 View Post
What about a little creative thinking to make the lift fit better.

Maybe route the top out some more to make the space wider, then make up a filler piece for a snug fit. Might work.

As for the vac fitting...surely there must be some way you can adapt that to work.
Thanks Keith, the vac fitting is a problem. I haven't put the router motor in yet and I'm hoping that the mechanism doesn't go any farther to crush the fitting. I'm still not sure it will work because of the angle and I will need to come up with a right angle fitting to go down. The flex hose will not bend that much. If that steel cross support bar wasn't there it would probably work I think.
JohnnyB60 is offline  
Sponsored Links
Advertisement
 
post #4 of 54 (permalink) Old 02-19-2016, 03:03 PM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Unhappy New Lift is not working

I bought this JessEm™ Rout-R-Lift II™ specifically for my PC 890 router and there is only one way it will fit into the lift, but the cord hits the slid bar and will not slide down all the way. In the photo I have the router turned so it looks like it will slide down, but there are little tabs that also need to line up. Even if I were to bend the cord out of the way as soon as I lower the lift the cord will hit.



Oh and the Vacuum fitting will not fit at all.
Dan_ likes this.
JohnnyB60 is offline  
post #5 of 54 (permalink) Old 02-19-2016, 06:14 PM
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Danny
Posts: 655
 
Default

If you are going to use the router motor in the lift only, why cant you remove the gear rack on the side and then turn it where the cord doesn't hit.
The Hobbyist likes this.

Making High Quality Kindling
jd99 is offline  
post #6 of 54 (permalink) Old 02-19-2016, 08:28 PM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Default

Quote:
Originally Posted by jd99 View Post
If you are going to use the router motor in the lift only, why cant you remove the gear rack on the side and then turn it where the cord doesn't hit.
thanks Danny, but it's the only plunge router that I have. I originally was planning on buying the Bosch 1617EVS Router to go with it it, but at this point I'm afraid to buy anything else for this router table. So far nothing has fit anything, from the dust collection to the lift to the router.

I also just found out that the lift plate doesn't come with the inserts and that's another $40. Who the hell doesn't use the inserts. Just another way for greedy bastards to bleed more money out of you.

I'm going to box everything up and return it.
JohnnyB60 is offline  
post #7 of 54 (permalink) Old 02-19-2016, 08:42 PM
Registered User
 
Join Date: Dec 2015
Country: Canada
First Name: Keith
Posts: 1,151
 
Default

Oh dear, this is not starting to sound good.

Is the Bosch router supposed to fit?

OK, fess up...which one of you clowns stole my sig? It was right here a second ago.
cocobolo1 is offline  
post #8 of 54 (permalink) Old 02-19-2016, 09:17 PM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Default

Quote:
Originally Posted by cocobolo1 View Post
Oh dear, this is not starting to sound good.

Is the Bosch router supposed to fit?
Hi Keith, I just don't know for sure. It says on the Jessem Site:
"THIS MODEL IS DESIGNED FOR USE WITH PC 690/890, BOSCH 1617/1618, DEWALT 610/618/616, CRAFTSMAN 1754/17540/28190
** 3.5" MOTOR DIAMETER **"

I just don't know what to believe anymore
JohnnyB60 is offline  
post #9 of 54 (permalink) Old 02-19-2016, 09:22 PM
Registered User
 
Join Date: Dec 2015
Country: Canada
First Name: Keith
Posts: 1,151
 
Default

Hmmmmm...curioser and curioser.

If it was supposed to work with your 890, maybe it's time to call Jessem and ask why it doesn't work with your router.

Is there any possibility that either the lift or the router may have undergone any sort of manufacturing change?

OK, fess up...which one of you clowns stole my sig? It was right here a second ago.
cocobolo1 is offline  
post #10 of 54 (permalink) Old 02-19-2016, 09:36 PM Thread Starter
Registered User
 
Join Date: Jun 2009
Country: United States
First Name: Johnny
Posts: 788
 
Default

Quote:
Originally Posted by cocobolo1 View Post
Hmmmmm...curioser and curioser.

If it was supposed to work with your 890, maybe it's time to call Jessem and ask why it doesn't work with your router.

Is there any possibility that either the lift or the router may have undergone any sort of manufacturing change?
I'm not sure if anything has changed, but except for the cord everything looks perfect.

I probably should try and contact Jessem, but I'm too upset right now. I've been waiting on buying this lift for about a year now. I was going to have my daughter purchase it for my Christmas present, but I got sick in November and missed Christmas all together because everyone thought I was going to die. So I finally feel well enough to buy it on my own and it just doesn't work.

Maybe I'll be calm enough on Monday to make the call.
JohnnyB60 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lee Valley dovetail jig oldrusty Jigs and Fixtures 25 03-22-2013 12:55 AM
Jig and Fixture parts kit from Lee Valley Cherryville Chuck Tools and Woodworking 6 05-27-2012 04:24 PM
Motorized Router Lift - Eagle Lake Style johnwnixon Table-mounted Routing 14 05-23-2012 05:51 PM
Lee Valley UHMW strips dask Table-mounted Routing 4 03-30-2012 01:20 PM
Lee Valley Tools TRN_Diesel Lobby 21 09-21-2010 04:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome