Router Forums banner

Candle sends all gcode lines at once, what am I missing?

1963 Views 4 Replies 4 Participants Last post by  PhilBa
Hi folks, I built my first grbl engraver today, from a kit on Amazon. Its firmware is 1.1. Working with the gcode below, which looks ok on, I can't get Candle to run the lines correctly. If I copy and paste each line into TeraTerm one at a time, and wait for one command to complete before pasting the next one, everything is fine. But that is not a good long term plan.

When I open the gcode file in Candle, all the lines show "In queue". When I click Send, all lines immediately go to "processed" and the spindle comes on, but the axes don't move. Because the spindle came on, I think the lines were all executed as soon as they came in to the control board. But there was no wait for any of the commands to complete. In TeraTerm, I didn't see any feedback from grbl saying that any of the commands were complete.

It feels like I'm missing some kind of secret handshake. Anybody got a hint? Thank you.

;seems to be calibrated in mm, but sometimes the controller acts like it read a number twice
;send via TeraTerm one line at a time.  Candle will not wait for a command to end before sending the next one.
;G90 ;set to absolute position: G91 is relative
G91 ;START at design top left
;G28 ;Move to Absolute Origin
G1 F50 ;You must set the speed before G1 works.  mm/min
M03 S1000 ; Spindle ON, speed "1000": OFF is M05
G1 Z-1 ;plunge
G1 X45
G1 Y-33
G1 X-45
G1 Y33
G1 Z1 ;withdraw
G0 X13 Y-20
G1 Z-1 ;plunge
G1 Z1 ;withdraw
G0 X6.1
G1 Z-1 ;plunge
G1 Z1 ;withdraw
G0 X-7 Y4
G1 Z-1 ;plunge
G1 Z1
See less See more
1 - 5 of 5 Posts
Welcome to the forum.
G'day. welcome to the forum.
Thanks for the welcome, gents.

I withdraw the question. This morning I tried it on a different PC and it worked fine. Both are Win10, so I don't know what the problem might be, except the the bad system has more recent updates. Candle also crashes on the bad system unless I delete settings.ini between runs. I guess I can figure it out from here.

Great forum, glad I found you.
  • Like
Reactions: 2
A suggestion, ditch Candle and try another sender. UGS works ok. I think you are on Windows so I recommend you try ioSender. Download the zip file, extract to a directory and run ioSender.exe
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.