Router Forums banner

CNC 3018 Pro Scaling(?) Issue

3931 Views 6 Replies 5 Participants Last post by  poolrod

I am working on CNC routing a piece that I made in the FreeCAD modeling software, but I am having issues when I export the file and try to get in to work on the CNC.
I am using a CNC 3018 Pro with the Candle software.
Firstly, I followed the 'Path Walkthrough for the Impatient' export guidelines from the FreeCAD wiki and it exported just as a 'File'.
So I manually changed the extension to '.nc' and it showed up in Candle.
However, the dimensions seem to be way off as the piece is supposed to be about 0.75" x 2" x 9.25", but according to the bottom left numbers in the display screen in the Candle software, it is (4746 x 1009 x 743, which I believe is in millimeters) which is WAY bigger. When I tried to start the job it just ran the Z motor to the top (I hit abort when the work coordinates hit 54 in the Z direction cause it was trying to send the router further than the machine allowed).
My question is- did I mess something up in the FreeCAD job or is it an issue with the CNC software? Why is it trying to send the router so high when it's only supposed to go about an inch high?
I have attached the Gcode, a screenshot of the 3D model with the path shown in green, and Candle software in case any of that is helpful.

Any help is greatly appreciated! Please let me know if there is any more information I can provide to be more informative on the issues I'm facing.


P.S. In case you aren't able to tell, I am new to both FreeCAD and the CNC/Candle.


See less See more
1 - 7 of 7 Posts
Welcome to the forum Gabriel. I'm not a CNC guy but I expect those that are will answer soon.
  • Like
Reactions: 1
Did you select Gcode as the export file type? That option is in a dropdown menu right under the box to name your export file.
I will try that, thank you!
Looks like you used the wrong Post Processor when saving your file. You need to use the GRBL Post Processor for your machine. Also, the gcode is set to use inches (G20) and it looks like your measurements are in mm in the FreeCAD file.

You might change the G20 to G21 in you gcode file so it knows those are actually mm
  • Like
Reactions: 1
Changing the post processor to GRBL fixed the issue, thank you all very much!
  • Like
Reactions: 4
I have the same problem, when I posted my Mastercam G-code file into Candle, it is running a lot smaller than my model and toolpath are. Yours is bigger, mine is smaller ha ha.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.