Router Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
hi
I am using a 5 axis cnc interface adapter breakout board for stepper motor driver Mach3 3& db25. the stepper motors are shinano 16z50g sst42d2120.stepper motors
The manual example uses a Mach 3 program setup. I am using i am kcam program with parallel ports.. the breakout board manual uses pins x 2 3 step and direction
the Enable uses a shared common #1 of which is set at #14 pin..
the kcam program uses separate pins for the Enable port setting ... it does not work either way of setting it up ..Do I have to use a driver board instead of the kcam software driver to get the Enable right or am I setting it up wrong ?
The stepper motors are pluged into the board and it is for a home made cnc rounter.
 

·
Official Greeter
Ross
Joined
·
11,170 Posts
Welcome to the forum. I can’t help with your inquiry but I’m sure someone will be along to give you a hand.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Welcome to the forum. I can’t help with your inquiry but I’m sure someone will be along to give you a hand.
thank you I hope someone can help...
I checked the parallel port pins with a volt meter from the computer they work ok checked the voltage outgoing of the breaker board they look good also.. i am buying a driver board .I hope it works. i will let you know...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
I haven't seen anyone using KCAM in over 15 years.
Just don't use the enables on the drives?
I started with Kcam years ago but real life took all of my time .. Its just a hobby for now...I am getting back into it now.. I downloaded linixcnc but have not had time to set it up yet. i don't know how good it is some people are raving about it... I don't know much about the other programs out there..
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top