Router Forums banner
1 - 4 of 10 Posts

· Registered
58 Posts
Discussion Starter · #1 ·
Anyone using the DDCSV3.1 Controller? This question is for you.

One of the remaining issues I have been struggling with is the discrepancy between the actual distance travelled (X or Y, it does not matter) and the coordinated displayed on the controller screen. For example, if I zero the coordinates in the home position and manually jog the gantry to the end of the Y-axis travel, the actual distance travelled is approximately 30 inches or 762 mm. However, the display indicates that the gantry has travelled 250 mm or about 10 inches.

It should be noted that the information available on-line indicates that parameter #115 is available to switch between imperial and metric units. However, this is not the case with my controller. Parameter #115 does not exist, and I can only work in metric units.

I checked the firmware version installed on my controller and noted that it was version 2018-08-13-99. I decided to upgrade the firmware to a newer version, 2020-03-06-112. The upgrade process was straightforward and posed no problems. You must start with a clean flash drive and decompress the ‘install’ files onto the flash drive. You then insert the flash drive into the controller and power the unit up. The upgrade process is automatic.

There are additional parameters that can be set to synchronize the actual travel with pulses received from the controller. These are Motor Parameters #34, #35, #36 and #38. The values for these parameters are the pulse equivalency for the X, Y, Z, and A axes, respectively. The units for pulse equivalency are given as pulses/mm and the range is 50 to 99999.000.

To calculate pulse equivalency, we start with the stepper motor spec sheet and determine that the motors have a step angle of 1.8o or 200 steps per revolution (360/1.8=200). So, each pulse will move the stepper motor one step. But we are using DM542T stepper motor drivers which have micro stepping capability. Using a micro stepping factor of 8 (8 micro steps for each pulse) we get 1600 pulses per revolution.

Next, we must convert the steps per revolution to linear distance traveled. The CNC router incorporates a timing belt drive which is the mechanical equivalent to a rack and pinion system. Our timing belt is a GT3 with a 3 mm (about 0.12 in) pitch and we are using a 20-tooth pinion gear attached directly to the motor.
To determine the number of pulses required per mm of distance travelled, we use the following formula:

PPU = (S x f) / (P x N)


PPU = pulses per unit of travel (mm)
S = Steps per revolution
f = micro stepping factor
P = belt pitch (mm)
N = No. of teeth on pinion gear

This results in a value of 26.67 pulses per mm of travel. This is the value that should also be represented on the controller display screen. Here is where we run into problems. The parameter entry page only allows us to enter values between 50.000 and 99999.000.

Has anyone else experienced this issue? Am I overlooking something obvious? Or did I buy a pig in a poke?

· Registered
58 Posts
Discussion Starter · #4 ·
I changed the microsteps from 8 to 16. The X-axis and the Z-axis now perform as they should. The displayed travel distance is now the same as the actual distance traveled.

The problem now is the Y-axis. It just sits there and stuttters.

I have two stepper motors moving the gantry. Each stepper motor has its own driver. Each driver uses a common signal from the controller. The controller does not allow for true slave mode.

I disconnected one of the motors and I was able to run the gantry back and forth. The distance travelled equals the displayed distance.

My two concerns are loss of torque due to increase in microsteps and how do I get both steppers to run on the Y-axis. I'm no expert but sounds like the two gantry drive motors are not in synch with each other.

· Registered
58 Posts
Discussion Starter · #7 ·
So that's why I earlier recommended that you change the physical pulley gear ratio.
since you are living in USA, you can always set your machine to run in inches instead of mm.
If you run in inches which is 25.4 times, you can always change the microsteps from 16 to 8 or 4 or 2 or 0 to increase the torque of the stepper motors.
When toque is increased, and both the Y-axis motors are moving, you will need to calibrated the 0 position of each side of the y-axis gantry.
I don't see how changing the pulley gear ratio is going to accomplish anything. If I increase the number of teeth on the pulley, it just makes the pulses/mm number even smaller. Remember, the firmware on the controller prevents me from going lower than 50 pulses/mm. If the effing firmware allowed me to go lower, I wouldn't have a problem.

The only pulleys I could find for GT3 belts are 20 tooth, 40 tooth & 14 tooth; none of these will correct the problem.

Despite what the literature says, I do not have a parameter in the firmware that allows me to switch between imperial and metric units. This is supposed to be parameter #115, but it doesn't exist on my controller - only metric (mm). I suppose that working in imperial units might solve the problem - depends on how the firmware is configured.

When I had the micro stepping set at 8, the two Y-axis motors worked together very smoothly. Switching to 16 micro steps solved one problem but created another.

I was hoping that somehow I had overlooked something obvious. At this point the only solution I see is to get a firmware version that allows me to switch between units and allows me to use a pulse/mm factor less than 50.

The other alternative is to switch to a Mach 4 controller. This would break my heart not only because of the additional cost, but also because of the hours I have put into this.

· Registered
58 Posts
Discussion Starter · #9 · (Edited by Moderator)
Now that the holiday guests have left, I resumed my inquiries into the CNC Router conundrum.

I did an internet search and found a site that purports to have the latest firmware ready for download. I downloaded the file and installed it on my controller. Lo and behold - I now have parameter #115 which allows me to change units from mm to inches. By switching to inches I was able to synch the actual distance traveled to the displayed distance. This means that all my work has to be done in imperial units, not metric which I prefer.

I connected both drive motors for the Y-axis and everything is running smooth at 8 microsteps.

The design of the belt drive does not permit swapping drive pulleys.
Bumper Gas Automotive exterior Machine tool Machine
Gadget Audio equipment Font Electronic instrument Communication Device
1 - 4 of 10 Posts