Router Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
As title states, I have the Dewalt DW618 router and the PC dovetail jig. I am using the miniature dovetail template that was included in the PC package.

I read in this forum and others that the guide bushings provided by Porter Cable should fit right onto my router and I'm good to go. I must be mucking something up because after installing the guide bushing and nut (hand-tightened) and bit, I turn my router on for 20 seconds. Within that 20 seconds, and not even trying to cut wood, the guide bushing becomes loose and turning around and around.

I read other threads here and the sticky notes which point to Amazon and a new base plate (I can't post the link as I'm a newbie to the forum).

Dewalt and PC web sites were not helpful. Should these 2 items work together? Do I need a sub-plate? Or am I simply not attaching the guide bushing correctly (??). Thanks.
 

·
Registered
Mike
Joined
·
3,941 Posts
Welcome to the Router Forums. Please fill out your profile, it helps when answering questions for us to know what tools you have available and also where you are located dictates where we might point you if you need parts, tools or other supplies for projects.

Sounds like you are not tightening the retainer ring for the bushing enough. I always use a wrench to tighten the ring then center the base of the router using the bushing to bit offset.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top