Router Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
917 Posts
Well I bought the same router a DW618, haven’t used it a lot but three months later I now have problems with it. I’ve noticed several times that the tone changes and I believe the speed is changing too. Today It made a horrible noise and the speed was changing so I went to adjust to a lower speed. The speed dial would barely turn, motor was hot, and when I started it up it went to full speed and stayed there regardless of settings. I’ve heard several complaints now of users that say it causes problems when used in a router table. The bearings are probably underrated and the dust causes problems. I find that the motor runs fairly hot and also that the collet area is fairly hot without a lot of use. I guess this is going back for repair under warranty. I am truly disappointed in this unit
I'm not sure about the speed controller on the 618. I know they were faulty on the 625.
 

· Registered
Joined
·
917 Posts
My issues are with older routers. I'm not sure if it was ever corrected. I may replace with the same speed controller as in the past or if it was corrected and is a new speed controller. Dewalt makes good products and as many have said it might just be a bad router. I have a DW618 under the tablesaw extension without a glitch. The 618 runs off and on were the 625 ran for long periods of time which may have had an effect on the speed controller from heat build up.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top