Router Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently acquired a Sawsmith RAS, and the camshaft on the yoke handle is frozen. I removed the knob, and have used PB blaster for over five days, yet the shaft is still frozen inside the aluminum handle itself. Any help would be greatly appreciated, as the rest of the saw is in great shape.
 

·
Registered
Joined
·
31,264 Posts
welcome Jkazak to the forum...

have you tried no flame heat (soldering iron/heat gun/hair dryer) and light shocks w/ a mallet...
have you ferrous and non-ferrous metals in contact w/ each other...

ramp up your rust/corrosion buster w/ a mix of ATF and acetone in a 1:1 ratio mix...
 

·
Registered
Joined
·
4,625 Posts
Sounds like some galvanic reaction going on between the aluminim shaft and its housing.

Heat and cold might help depending on how welded they are ro each other...

Do not succumb to the "bigger hammer solution"...
 

·
Retired Moderator
Joined
·
16,385 Posts
Welcome Jkazak. Try the above solutions first especially a little heat.
 

·
Official Greeter
Ross
Joined
·
8,323 Posts
Welcome to the forum Jkazak.
 

·
Official Greeter
Joined
·
18,742 Posts
Welcome to the forum...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #8
After more than two weeks of trying, everything under the sun and then some. the handle is finally free. I have worked on a lot of stuff over the last fifty years but I never saw anything as frozen as that.
 

·
Official Greeter
Ross
Joined
·
8,323 Posts
After more than two weeks of trying, everything under the sun and then some. the handle is finally free. I have worked on a lot of stuff over the last fifty years but I never saw anything as frozen as that.
Great result, congratulations.
 
1 - 9 of 9 Posts
Top