Router Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I read a couple of post that mentioned the problem I'm having and that is, the 1/4 collet adapter for the harbour freight 1 3/4 router lets every bit fall out.
Has anyone found a solution to this.
I want it known that I didn't buy this new at the store but from an individual. I had never owned a plunge router and thought this would be a good learning tool.
Not happening as of this post.:(
 

·
Official Greeter
Joined
·
18,811 Posts
Welcome to the forum, Chuck.

It sounds like the collet is faulty/damaged.

Is it a 2 part collet which may not be assembled correctly?
 

·
Super Moderator
John
Joined
·
6,941 Posts
Hello Chuck
Welcome to the forum.
Agree with James buy a new collet and try it, and make sure you have the right one
 

·
Official Greeter
Ross
Joined
·
9,359 Posts
Welcome to the forum Chuck.
 

·
Registered
Joined
·
2,983 Posts
MHO Don't buy HF tools. For a few dollars more you can buy brand name items that work properly. Learned my lesson sometime ago.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Thank you for the info. I will try that collet adapter. It doesn't look like the one that was in the plastic ziplock bag with several other attachments. If I buy this for $10 with all of the shipping charges I will have a $55 investment. Not bad really if it works.
The picture of this one you suggest has a flange on top which will keep it up top in the 1/2" collet.
As I said,I will try it.
csage3
 
1 - 8 of 8 Posts
Top