Router Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just purchased the powermatic 2x4 cnc router. I got it up and running perfectly. This morning however when i turned it on the inverter screen was flashing F11. Everything functioned completely normal except the spindle wouldn't turn. I tinkered with stuff and got in running, but the spindle would stop mid run and the same code F11 would be flashing again. This is really bad because everything else was still moving. I'm guessing this could seriously damage the machine. Any thoughts of how to fix this issue.
 

·
Registered
Joined
·
413 Posts
Welcome Eric, I just looked through the online Powermatic cnc manual and they don't list any error codes. I'd call them.
Good luck.
 

·
Super Moderator
John
Joined
·
6,962 Posts
Hello and welcome to the router forum,
You got my luck I also got the newest model, only guy that understands it is on vacation
 
  • Like
Reactions: Roland Johnson

·
Official Greeter
Ross
Joined
·
10,022 Posts
Welcome to the forum Eric.
 

·
Registered
Joined
·
198 Posts
is the inverter (screen) what provides the power to your spindle? what is the make/model number? as mentioned, you definitiely want to consult the factory. i agree that it may not be wise to run, as bits snap quickly. $$

looks like a nice machine!
 

·
Administrator
David
Joined
·
3,976 Posts
The tech guy said he had to talk to an engineer because I have the model with all the latest updates. I am waiting for a call back.
They may be waiting on the engineer for whoever builds the machines for them.

David
 

·
Registered
Joined
·
140 Posts
F11 is usually a motor overload. Go in and adjust the peramenter. If you use a large bit or try to cut too much at one time you could bog the motor down enough to get this code.
 

·
Registered
Joined
·
372 Posts
The powermatic is a clone of the Axiom (and similar sized laguna, etc). You might want to check on their forums. The powermatic "Engineer" for the machine is probably in Taiwan, and they might be having translation issues, that factory certainly does not manufacture the VFD, that would involve another supplier, possibly (likely) in china.
 

·
Registered
Joined
·
1 Posts
I just purchased the powermatic 2x4 cnc router. I got it up and running perfectly. This morning however when i turned it on the inverter screen was flashing F11. Everything functioned completely normal except the spindle wouldn't turn. I tinkered with stuff and got in running, but the spindle would stop mid run and the same code F11 would be flashing again. This is really bad because everything else was still moving. I'm guessing this could seriously damage the machine. Any thoughts of how to fix this issue.
I have the same problem, are you able fix it. Thanks
Tsechang
 

·
Official Greeter
Ross
Joined
·
10,022 Posts

·
Official Greeter
Joined
·
19,110 Posts
1 - 15 of 15 Posts
Top