Router Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I own a small woodwrking shop on Maui and have just inherited a Holzher 1432 express edgebander. It sat neglected for a couple of years before acquired it in exchange for a 12 pack of beer. Starting to think i got the short end of the stick. I completely disassembled it, cleaned, oiled, replaced air lines, sharpened trimmers and put it back together. I measured all settings with a micrometer before i took it apart to insure it went back together the same way. It started up properly and with a few minor adjustments i was edgebanding test pieces. For about 5 minutes. The top trimmer motor squealed for about 10 seconds and then froze up completely. Melted the front bearing into the motor housing.
I have been looking online for new or used replacement parts and have not had much luck. Anyone know of a good resource for parts? Thanks in advance for any help!
 

·
Official Greeter
Joined
·
18,790 Posts
Welcome to the forum, Kirk.

Can you take the motor and bearing to a bearing supply company to see if they can replace the bearing.

A lot of machine bearings come in standard sizes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks James, It got so hot that the bearing melted the motor housing and cooling fan. Unless i can turn back time, it looks like i need a new motor.
 

·
Official Greeter
Joined
·
18,790 Posts
Thanks James, It got so hot that the bearing melted the motor housing and cooling fan. Unless i can turn back time, it looks like i need a new motor.
Or another 12 pack bargain.......LOL
 

·
Registered
Theo
Joined
·
7,093 Posts
Welcome aboard. The magic 8 ball says to check with an electric motor repair shop, see what they say.
 
1 - 5 of 5 Posts
Top