Router Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
I am having issues with my T8 CNC from Gearbest. I can manually control using grbl controller including starting spindle and manually moving XYZ. Using Easel however I can setup the machine and it will start spindle but hitting Carve button, within moving a few mm it all stops. Exporting gcode and sending from grbl controller does the same.
Any suggestions? Connection seems temperamental too.
 

·
Super Moderator
David
Joined
·
3,583 Posts
Welcome to the forum! When you get a minute complete your profile with first name and location.

I'm not familiar with that setup but maybe one of our other CNC guys will be along shortly to assist. By 'connection seems temperamental' do you have specifics?

David
 

·
Registered
Joined
·
1,171 Posts
On the CNCs I oversee, the things that stop a cut in progress include hitting a limit switch, or the e-stop, or the stop/pause buttons in the control software.
I'd check your limit switches for sensitivity, as in sudden vibration setting them off.

4D
 

·
Registered
Joined
·
3,730 Posts
Welcome to the Router Forums.

Are you using the correct post processor for your machine? If the post processor is wrong then it could be compiling bad gcode for that CNC.

Almost sounds like your file just contains the end shutdown codes and no actual machining moves. You should be able to view the gcode in a word processing software, I use notepad, to see if there are machining commands or just code that shuts down the spindle and ends the program.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
The basic setup does not have any endstops, so won't be that. As I said, I can manually control with no issues, so it does seem to be related to streaming the gcode.

When I say connection temperamental, I can click connect on grbl controller a few times before it connects and with Easel it can take a few attempts to see the Arduino connected.

As far as streaming gcode, sending via grbl controller I see several G1 commands sent but of course it does not complete these as it just halts (with the need to power cycle the Arduino).
 
1 - 5 of 5 Posts
Top