Router Forums banner

Triton trb001 brushes seized

4399 Views 12 Replies 4 Participants Last post by  sebmoc
Good afternoon, UK time.

I have just joined your forum in the hope of some advise. I have emailed Triton but no response. I have a TRB001 router which stopped working during door making. Up until now most of my router work has been 'freehand' so to speak but progressed recently to my Triton workcentre. Testing depth of cut for cutters I went to start machine after adjustment and refused to work. I have read posts about it could be the switch, speed controller or brushes. I purchased a new TRA001 but would like to get this TRB001 working as it, as far as I know as I was given it, does not have excessive hours on it. I have looked at the brushes and one of them appears to be frayed on the wiring and both are stuck in place. Enough 'waffle'!

My question is:- How can I remove these brushes for replacement without pulling on them with the risk of making matters worse?

I await any suggestion.

Many thanks in advance.
1 - 13 of 13 Posts
brushes are held in place by spring clips, or sometimes folded over tabs.. Just look closely at what is holding the brush spring in place and find a way to remove it.
Hello Sunnybob. Thanks for your reply but on the Triton TRA/B001 it is held in place by the brush holder with a cap screw. The brushes should just slip / pull out but even with quite a bit of force they will not budge. They do not seem to be twisted but are stuck solid.

My thoughts are maybe they have expanded. Do brushes expand?

I have placed router, with top cover off, upside down, on top of the radiator with the hope that heat will shrink the brushes if my assumption is correct.

To remove the brush holders I need to have the brushes out as I thought maybe replace brushes and holders in case it is both giving trouble.

Maybe someone here has some thoughts or suggestions on this.
Ok, you have option three (lol)
The brushes are solid carbon. They dont expand. It sounds like they have worn so much that there are broken bits jamming them down. Its extremely unlikely you will be able to save those brushes, so you could just break them out with a fine bladed screwdriver, to see in the commutator ring is ok.
Thanks again.

They do not seem that worn but your suggestion to break them out is my thoughts exactly but I did not know whether it maybe an option. Being that you have suggested the same option then I think that will be the way to go.

Many thanks for your time. I shall post results in case it may help someone else.
Lets back up a bit before you start destroying stuff.
Does the spindle turn?
if so, does it turn freely?
If so, have you checked the fuse in the plug? It should be a 13 amp fuse. If you have no way of testing, swap it into another appliance that does work.

Do you have any circuit tester (preferably a multitester that measures AC voltage?)

Lets eliminate the simple things first.
It doesn't look like anything should be holding them (parts 26, 27, 28, and 29 the caps):
Maybe a pair of needle nose pliers and wiggling them back and forth would loosen them.
All was covered before even posting on here.

Everything worked as it should movement wise.

Power light on switch.

No movement on brushes with whichever implement I tried to move them with.

Finally, toooo late because I have 'smashed' them out.

Just so as not to horrify you. I am a retired tradesman of many years and used to repairing my own tools. Generators, of which I have 3, dewalt chop and bench saws along with numerous drills of many types. Dewalt routers of which are 20+ years old and maintained by self along with numerous other tools including these two triton routers of which one is not even a week old yet bought as replacement for this TRB001.

As stated, the brushes have been broken out and all looks alright. The cause seems to me to be the fact that the brushes corroded to the brush holder. Now the brushes are out there is green corrosion stain on the sides of the brush holders. Nothing that cannot be cleaned.

Thank you again for your replies and time on this issue.
See less See more
  • Like
Reactions: 2
Glad you resolved the problem. I have and really like the TRA001, but only use it in the table. The switch interlock on the TRA is a love it or hate it thing. Also with the router raised to it's full height for a bit change, it won't run--safety feature.
The corrosion probably increased the diameter a bit as well as welding the pieces together. Are there wires going to the brushes or do the brush holding cups transmit the current to the brushes?
There is a wire from brush to plate at top with screw in caps over the brush holder.

When the TRB001 was working I tried it 'freehand' but could not get on with the switch. From then on it was mounted in the table.

For 'freehand' work I much prefer the Dewalt plunge router with the up and down switch by the left side handle. It is so easy to switch on and off with finger whilst holding and also operating in jig especially if you have set a depth without depth stop and do not wish to disturb that setting.
Just a quick update to this problem. I received my replacement brushes this morning, installed them and everything is working now as it should.

Thank you all for your suggestions and hope if someone has the same or similar problems this post maybe of help to them.
  • Like
Reactions: 1
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.