Steel City table saw switch issues - Router Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-12-2010, 11:47 PM Thread Starter
Forum Contributor
 
Join Date: Jun 2009
Country: United States
First Name: John
Posts: 3,046
 
Default Steel City table saw switch issues

Hi guys n' gals - I was over at a friends shop this afternoon and he just had his third power switch fail on his 6 week old Steel City saw. He's not on the internet so he asked me to see if I could find out if this is a common problem for other owners, it certainly is for him. The model number he has is 35915G, 3HP.

John Schaben

The problem with experience is I usually get it immediately after I need it.
jschaben is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-13-2010, 08:21 AM
Registered User
 
dutchman 46's Avatar
 
Join Date: May 2007
Country: United States
First Name: Howard
Posts: 2,825
 
Default

It's hard to say. I haven't seen any body complain. It is possible that the manufacturing co. got some bad ones from the maker. You can wait and have others who have had problems. Thats the most probable cause. Where Hr keeps it as far as moisture, is another.

John 3:16

Please fill out your profile, It helps us to know you better
dutchman 46 is offline  
post #3 of 3 (permalink) Old 10-14-2010, 05:36 PM Thread Starter
Forum Contributor
 
Join Date: Jun 2009
Country: United States
First Name: John
Posts: 3,046
 
Default

Quote:
Originally Posted by dutchman 46 View Post
It's hard to say. I haven't seen any body complain. It is possible that the manufacturing co. got some bad ones from the maker. You can wait and have others who have had problems. Thats the most probable cause. Where Hr keeps it as far as moisture, is another.
Hi Howard, I'm thinking it's a vendor issue also, just trying to find out if it's wide spread or not.
No moisture issues with this guys shop. He retired a couple of years ago and had a 20x40 ft steel building put up dedicated to his woodworking. Central heat and air to boot. Didn't spare much, about the only thing he didn't put in was 3 phase electric service. Yeah, I'm jealous, but on the other hand, he has the skils to use all that stuff too.

John Schaben

The problem with experience is I usually get it immediately after I need it.
jschaben is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Router Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Router Table for Incra LS Positoner completed! Michael H Table-mounted Routing 35 03-19-2015 12:40 PM
Switch for router table or any motor device mewoodwork Table-mounted Routing 1 07-18-2010 10:58 PM
How do I mount a Router to a table demaX Table-mounted Routing 3 04-16-2009 06:56 AM
router table xplorx4 Table-mounted Routing 11 12-18-2008 12:45 AM
Sold: Router Table or Table Top -Sam- Woodworking Classifieds 10 01-29-2005 09:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome